I'm exporting my bank history using OFX format and GnuCash can import it ok, but sometimes there are a few transactions that are in the bank history, are in the OFX file, but GnuCash refuses to show the transaction in the import dialog. What could be happening?

1 Answer 1


What could be happening:

  • The OFX file being imported could be malformed, and the "bad" transactions are being ignored during import (unlikely if the data is coming directly from your bank and isn't being modified by you after download).
  • The transactions overlap with other transactions already imported. While this is possible, I don't believe it's how the software behaves (it should show you the conflicting transactions and prompt you to mark them as duplicate).

A couple of steps you could take to troubleshoot the problem:

  • Enable logging in the application and check there for any error messages after an import.
  • Take note when a transaction is excluded, then export an OFX file from your bank containing only that transaction (a 1-day range, for example). Try to import just the one transaction and see how it behaves.
  • If you can prove that what you're seeing is a legitimate bug, you can contact the developers via IRC and file a bug report.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .