7

Prior to the update to version 3 (ie, the 2.6 branch), all my funds were tracked with decimal values. Now, they're all fractions... and odd ones, at that.

Do I really care that shares went from trading at 45 + 5/6, then went down to 44 + 47/117, and finally traded at 46 + 4/11?

No. No, I don't.

I want the decimal values. They mean more to me, and they're actually how I'm entering my data anyway.

Unfortunately, I can't figure out how to turn this off. Please, how do I get my sanity back?

  • Um yep - strange. For what it's worth, as soon as you click to edit, the decimal value is displayed for editing. But still, I'm yet to see a broker report prices in that format. I'm guessing somebody went rogue on this one. Posted to gnucash-users - if an answer is to be had, it will be had there relatively quickly. – Andy Jun 8 '18 at 4:46
2

To follow up in 2019, gnucash version 3.3 and later have fixed the bug discussed in the other answer by Geert Janssens. But you must go to Preferences -> General and select Force Prices to display as decimals. This will cause the prices to be rounded.

5

This is a bug:

https://bugzilla.gnome.org/show_bug.cgi?id=794755

Unfortunately nobody has found time to fix it yet...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.