-2

I moved my Gnucash files between PCs. I transferred all Gnucash files at my particular location that I consider for further moving process and keep them particularly in a folder then transferred them. I installed finance quote also before opening my account. I transferred between the same versions even not mentioned standard on the documentation of 2.6.1. Migrating financial data. It was looks good at first glance, but it so weird in details.

Version: 5.4
Build ID: 5.3-412-g53245caebf+(2023-09-23)
Finance::Quote: 1.58

The data appeared good, double book keeping entries works with credit card under liability and fetching quotes worked efficiently. However, I noticed double bookkeeping entries displaying --split transaction-- instead of withdrawing from the bank account, as set on the host PC.

Further, the column titles for stock data changed during the transfer from transfer, debit, credit, and balance to shares, price, buy, sell, and balance

Afterward, I also transferred the directory ~/.cache/gnucash. Despite this, the data transfer process did not complete efficiently.

I attempted to open a new account on the target PC, and everything appeared normal in the stock section.

How can I fix this problem,

2
  • 1
    This seems like a tech support issue, not a financial literacy question. Personally, I've moved GnuCash files multiple times without any incident, you're describing something way more complex than it needs to be
    – littleadv
    Nov 15, 2023 at 22:20
  • This was amazing point for me to further interactions, so could you have any suggestion for fix this drawback. I don't have any financial background. Additionally, I stuck on this issue but couldn't find any forum for asking like this questions. At least few days later while writing this issue, I realized this point. I couldn't throw away.
    – maxemilian
    Nov 17, 2023 at 5:42

2 Answers 2

1

As you probably know, GnuCash has separate configuration files for things like display options and report settings that are maintained in different locations to the main data file containing transactions. So simply transferring a data file to your new PC does not guarantee that everything will work the same / look the same as it did on your old PC.

I think that this tickbox setting enter image description here found in the Accounts tab of the Preferences dialogue box (Edit/Preferences) will probably explain why "the column titles for stock data changed during the transfer from transfer, debit, credit, and balance to shares, price, buy, sell, and balance".

My best guess about the reason that a transaction that previously linked to a bank account should suddenly show as a "--split transaction--" is that the new GnuCash installation is using a different Viewing style for that account register. Maybe try experimenting with Basic Ledger or Auto-Split Ledger or Transaction Journal (all of these are options on the View menu) to see if the transaction is still the same when viewed with the appropriate View style.

0

Gnucash has more than double book keeping entry for stock.

Probably, you're looking to

Trading -> Stock

should look correct section

Asset -> Investment -> Stock section

Not the answer you're looking for? Browse other questions tagged .