I am downloading my banking transactions and importing into GnuCash (v3.11) via QIF. I have set up auto scheduled payments that are not being matched to imported transactions.

GnuCash only seems to match existing transactions when the payee and amount are identical. Many companies append the payee with transaction specific info. For example, instead of "XYZ Insurance", the payee will be "XYZ Insurance Transaction #123". I am ending up with lots of duplicate entries because of this and have to manually hunt them down and delete.

Anyone else have this problem and anyone found a good solution?

1 Answer 1


I haven't experienced your problem, but I know that the GnuCash Preferences screen (Edit > Preferences) allows you some control over the way that the import process goes about the matching process.

On the GnuCash Preferences screen, select Import on the side menu. You will then be able to configure a number of parameters that affect the import process. For example you can specify how close two dates have to be before they can be considered to potentially apply to the same transaction. You can choose to use bayseyian matching, or not. And so on.

  • Hmm. v3.11 (I'm on Windows 7) doesn't have an "Import" option in preferences. Perhaps they've added that with the new version. I'm needing to wait another year before upgrading my Windows 7 machine OS as it will take days of configuring. Looks like the newer version may address some of this. If not (and in the meantime), I may write some code to strip out the offending parts of the Payee Name in my import file. This may be the easiest and most satisfying in the end.
    – mseifert
    Aug 12, 2021 at 19:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .