2

When I begin reconciling an account in GnuCash, the statement date field is populated with a value that seems to be random. Is there a way to make it default to the current date?

2
  • 3
    I don't think it's random; it's usually the same day as the previous reconciliation, but one month later. So if your last reconciliation used a statement date of 2020-02-02, the next one will use 2020-03-02. That said, the same shortcuts work in all date fields: typing t sets it to today.
    – chepner
    Mar 2 '20 at 18:02
  • 1
    @chepner: Great, thanks. If you enter this as an answer, I'll accept and upvote it.
    – Tony
    Mar 2 '20 at 19:05
1

Tony, there IS a way to make it default to today's date.

If you open Edit / Preferences, then select the Register tab, you will see a tickbox option for "Always reconcile to today". The helptext indicates that the result of ticking this box will be Always open the reconcile dialog using today's date for the statement date, regardless of previous reconciliations.

I think that is what you are after.

0
5

While I don't know of a way to make today's date (rather than what I believe to be one month following the previous reconciled statement's date) the default, you can press t in any date field to cause the current day's date to be entered.

1
  • FWIW, the date still seems random. I last reconciled an account on 2/29; the latest date populated was 2/22. Weird.
    – Tony
    Mar 3 '20 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.